Page MenuHomeSolus

git: Update to 2.32.0
Needs ReviewPublic

Authored by ReillyBrogan on Wed, Jun 9, 5:09 AM.

Details

Reviewers
JoshStrobl
Group Reviewers
Triage Team
Summary

Release Notes:

Packaging Notes:

  • Several rundeps have been dropped:
    • perl-io is part of the Perl package now
    • perl-libnet is also part of the Perl package (the Perl library version is newer than the version in perl-libnet)
    • perl-mime-base64 is also part of the Perl package
    • SSL support was added to the Net::SMTP library directly (also part of the Perl package). perl-net-smtp-ssl is only used by Git if Net::SMTP is older than version 2.64 (the Perl package version is 3.11)
    • perl-net-ssleay is used by perl-io-socket-ssl but is not used by git directly
  • zlib has been added as an explicit builddep
Test Plan
  • Committed this diff
  • Rebased a few patches
  • Cloned a repo from Github
  • Generally checked that common workflow things like branching and merging worked

Diff Detail

Repository
R909 git
Branch
arcpatch-D11246
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 764
Build 764: arc lint + arc unit

Event Timeline

ReillyBrogan created this revision.Wed, Jun 9, 5:09 AM
ReillyBrogan requested review of this revision.Wed, Jun 9, 5:09 AM
JoshStrobl requested changes to this revision.Wed, Jun 9, 3:45 PM
JoshStrobl added a subscriber: JoshStrobl.
JoshStrobl added inline comments.
package.yml
19

This isn't needed, it is part of system.devel

This revision now requires changes to proceed.Wed, Jun 9, 3:45 PM
  • Remove zlib
ReillyBrogan planned changes to this revision.Thu, Jun 10, 4:29 AM
ReillyBrogan marked an inline comment as done.
ReillyBrogan requested review of this revision.Thu, Jun 10, 5:17 AM

Don't hate me but you will need to rebase this. Just in case, I opted to just bump and rebuild this during our glibc upgrade. Not that I don't trust your testing, just didn't want to risk borking git while we're trying to update hundreds of packages :D