Page MenuHomeSolus

Update pentobi to 19.0
ClosedPublic

Authored by algent on Tue, Apr 20, 11:20 AM.

Details

Summary

Changelog:

  • The minimum required Qt version is now 5.15.
  • Support compilation with Qt 6.
  • The desktop version now always displays the manual with an external browser, which removes the dependency on the Qt WebView library and the compilation option PENTOBI_OPEN_HELP_EXTERNALLY.
  • The Qt SVG library is no longer needed.
  • Loading game files in encodings other than UTF-8 is no longer supported.
  • Complete Russian translation of the manual.

Signed-off-by: Algent Albrahimi <algent@protonmail.com>

Test Plan
  • Start game, save, open saved game.
  • Export as PNG image and TXT with ASCII Arc Option.

Diff Detail

Repository
R2315 pentobi
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

algent created this revision.Tue, Apr 20, 11:20 AM
algent requested review of this revision.Tue, Apr 20, 11:20 AM
DataDrake accepted this revision.Fri, Apr 23, 3:27 PM
DataDrake added a subscriber: DataDrake.

LGTM. Thanks!

This revision is now accepted and ready to land.Fri, Apr 23, 3:27 PM
This revision was automatically updated to reflect the committed changes.